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Global gradient algorithm (GGA) : How to solve for the pressure dependent
demand. Conventionally, nodal demand is a known value. Applying the mass
conservation law to each node and energy conservation law to each loop, the network
hydraulics solution can be obtained by iteratively solving a set of linear and non-
linear equations. A unified formulation for solving network hydraulics is given as a
global gradient algorithm (GGA).

An Ag

Q —A10H,

™ 0 |ly —q

Where Q is the unknown pipe discharge and H is the unknown nodal head. q is the set
of nodal demand that is not dependent on the nodal head H.

For pressure dependent demand, the demand is no longer a known value but a
function of nodal pressure. The solution matrix becomes:
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Az Ay | LH —-q
A new diagonal matrix Ay, is added to the solution matrix. The non-zero diagonal
element is given as

Ay (4,1) = QF

Direct GGA Solution :An alternative solution method is to directly apply GGA as
derived but move the pressure dependent demand term to the right
All A12

Q —Aq0H,

Agq 0 |LH —AH —q
This method require no matrix modification of original GGA, but the program will

update the nodal demand according to the pressure head of the left side of the matrix.

Modified GGA Solution : By following the original derivation of GGA, pressure
dependent demand formula can be solved as:

dE]

dq

The difference from the original GGA is the new diagonal matrix D22, which is
the deviation of A22 of pressure head H.

D14 A1z | [dQ

Ayq Dy, | LdH

0

" PF <0
D,,(i,i) = a(ﬁ)“‘l % Q 0<P<P
0 l Pis 2 P

The modified GGA is to calculate D22 for each pressure dependent demand node
and add at A(i, i) as follows:

A(i,1) = Xjpij — Daz(1,1) , where the pipe j is connected with node i.
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Example: Performing a Steady-State Analysis on WaterCad:

In constructing a distribution network, no need to be concerned with assigning labels
to pipes and nodes, because WaterCad will assign labels automatically. When
creating a schematic drawing, pipe lengths are entered manually. In a scaled drawing,
pipe lengths are automatically calculated from the position of the pipes' bends and
start and stop nodes on the drawing pane.

In this network, the modeling of a reservoir connected to a pump simulates a
connection to the main water distribution system. Simplifying the network in this way
can approximate the pressures supplied to the system at the connection under a range
of demands. This type of approximation is not always applicable and care should be
taken when modeling a network in this way. It is more accurate to trace the network
back to the source.

Step 1: Create a New Project File

Using the WaterCad interface:

1. Double-click the WaterCad icon. The welcome dialog box opens.

35


javascript:WebWorks_ToggleDIV('exwp8329160');

N

Click Create New Project and an untitled project opens.

3. Choose Tools > Options > Units. Since you will be working in System
International units, click Reset Defaults to System International.

4. Verify that the Default Unit System for New Project is set to SI. If not, select

from the menu.

5. Select the Drawing tab to make sure Drawing Mode is set to Scaled.

6. Set the Horizontal Scale Factor 1 cm =40 m.

7. Click OK.

8. Set up the project. Choose File > Project Properties and name the project.
click OK.

9. Choose File > Save As. In the Save As dialog box, double-click the any
folder.

10. Enter the file name any.wtg for your project and click Save.
Using the AutoCAD interface:

1. Double-click the WaterCad desktop icon to start WaterCad for AutoCAD.

2. Choose Tools > Options > Units. Since you will be working in System
International units, click Reset Defaults to System International.

3. Verify that the Default Unit System for New Project is set to Sl. If not, select

from the menu.

Click OK.

Click the File menu and select the Project Properties command. Type any in

the Title field and click the OK button.

6. Change the project Option settings. Click the Tools menu and select the
Options command. Change to the Drawing tab.

7. Change the Drawing Mode to Scaled. Set the horizontal scale to 1 mm =
4000 mm.

8. Click the OK button to continue.

o~

Step 2: Lay out the Network

=

Select Pipe from the layout toolbar.
2. Move the cursor on the drawing pane and right click to select Reservoir from
the menu or click from the toolbar.
Click to place R-1.
4. Move the cursor to the location of pump P-1. Right-click and select Pump
from the shortcut menu.
Click to place it.
Right click to select Junction from the menu and click to place J-1.
Click to place junctions J-2, J-3, and J-4.
Click on J-1 to finish.
Right-click and choose Done from the menu.
Create J-5.
a. Select the Pipe layout tool again.
b. Click junction J-3.
c. Move the cursor to the location of J-5, and click to insert the element.
d. Right-click and select Done.
10. Insert the PRV from the menu and junction J-6 by selecting the Pipe layout
tool and placing the elements in their appropriate locations.

w

©ooN O
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Be sure to lay out the pipes in numerical order (P-7 through P-9), so that their
labels correspond to the labels in the diagram. Right-click and select Done
from the menu to terminate the Pipe Layout command.

11. Insert the tank, T-1, using the Pipe layout tool. Pipe P-10 should connect the
tank to the network if you laid out the elements in the correct order.
12. Save the network by clicking Save or choose File > Save.

Step 3: Enter and modify data

o Dialog Boxes—You can use the Select tool and double-click an element to
bring up its Properties editor. In AutoCAD, click the element once with the
Select tool to open the element's editor.

e FlexTables—You can click FlexTables to bring up dynamic tables that allow
you to edit and display the model data in a tabular format. You can edit the
data as you would in a spreadsheet.

o User Data Extensions—The User Data Extensions feature allows you to
import and export element data directly from XML files.

« Alternative Editors—Alternatives are used to enter data for different “What
If?" situations used in Scenario Management.

Entering Data through Dialog Boxes

To access an element's dialog box in WaterCad V8 Stand Alone mode, double-click
the element. In AutoCAD, first click the Select tool on the toolbar, then click the
element whose attributes you wish to modify to open the Properties window.

1. Double-click on the reservoir R-1.
2. Enter the Elevation as 198.
3. Set Zone to Connection Zone.
Click the menu to Edit Zones which will open the Zone Manager.
Click New.
Enter a label for the new pressure zone called Connection Zone.
Click Close.
Select the zone you just created from the Zone menu.
f. Close the Reservoir Editor.
4. Now double-click on tank T-1 and enter the following:
Elevation (Base) = 200
Elevation (Minimum) = 220
Elevation (Initial) = 225
Elevation (Maximum) = 226
Diameter (m) =8
Section = Circular.
Create Zone-1 and set the Zone value to it.
Close the Tank editor.
5. Click on pump PMP-1.
a. Enter 193 for the Elevation.
b. Click in the Pump Definition field and click on Edit Pump Definitions
from the drop-down list to open the Pump Definitions manager.
c. Click New to create a new pump definition. Name it PMP-1.

®o0 o
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d. Select Standard (3 Point) from the Pump Type menu.

e. Change the flow units by right-clicking on Flow to open the Units and
Formatting menu.

f. Click on it and then, in the Set Field Options box, set the Units to
L/min.

g. Click OK.

h. Enter the Flow and Head informatio.

i. Click Close.

. Highlight PMP-1 in the drawing view and change the Pump Definition
value in the Properties viewer to PMP-1.

6. Click on the valve PRV-1. Enter in the following:

Elevation =165

Diameter = 150

Pressure Setting = 390

Status = Active

Setting Type = Pressure.

Create Zone-2 and set it.

Click to exit.
7. The Properties window for the junctions will look like this:
Enter the following data for each of the junctions, leaving all other fields set to
their default values.
In order to add the demand, click the ellipsis in the Demand Collection field to
open the Demand box, click New, and type in the numbers for Demand
(Base). Choose the Fixed Pattern.
Click to exit.
9. Specify user-defined lengths for pipes P-1, P-7, P-8, P-9 and P-10.

a. Click on pipe P-1 to open the Properties window for the pipe.

b. Set Has User Defined Length? to True. Then, enter a value of 0.01 m
in the Length field. Since you are using the reservoir and pump to
simulate the connection to the main distribution system, you want
headloss through this pipe to be negligible. To model this, we assign a
very small value to the pipe length and a large value to the pipe
diameter.

c. Enter 1000 mm as the diameter of P1.

d. Repeat for pipes P-7 through P-10 using the following user-defined
lengths:

P7 =400
P8 =500
P9 =231
P-10 = 100.
e. Clickto close.

2

Step 4: Entering Data through FlexTables

It is often more convenient to enter data for similar elements in tabular form rather
than to individually open a dialog box for an element, enter the data into the dialog
box, and then select the next element. Using FlexTables, you can enter the data as you
would enter data into a spreadsheet.

To use FlexTables
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Click FlexTables or choose View > FlexTables.

Double-click Pipe Table to open the Pipe FlexTable. Fields that are white can
be edited but yellow fields cannot.

For each of the pipes, enter the diameter and the pipe material,

In order to enter the material type, click the ellipsis to open the Engineering
Libraries box. Click on Material Libraries > Material Libraries.xml and then
click the appropriate material type and then click Select.

Or, enter the material type in the field.

Notice that the C values for the pipes will be automatically assigned to preset
values based on the material; however, these values could be modified if a
different coefficient were required.

Leave other data set to their default values. Click to exit the table when you
are finished.

Step 5: Run a Steady-State Analysis

=

ok w

~No

Click to open the Calculation Options box.

Double-click or right-click on Base Calculation Options to open the Properties
manager and make sure that the Time Analysis Type is set to Steady State.
Click to close.

Click Validate, then click OK if no problems are found.

Click Compute to analyze the model.

The Calculation Summary dialog box opens.

A green light indicates no warnings or issues, a yellow light indicates
warnings, and a red light indicates issues.

When calculations are completed, User Notifications opens.

Click to close User Notifications.
Click to Save project.
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.Hazen - Williams _s! Darcy-Weisbach 48de (je HUa8Y) a3aa3 oSy

Lag o guaially el A83e ot (il A (e (528 123 gea (A Al Jla -
At=4 hrs 4uie ) shad JS a8al) 8 cilysaidl ol lginl axy 5 ¢1.3 Jynall A
Al o saa Clus (S 401 A8ST SDGLY) e (e 2.3 sl (A
Jaras 4-12 hr Acie I 358l JOA olaalls (1) o) Jad) (6385 3.3 Jsaall A A
12-20 hr 4xie I 3 58l JA slaalls (2) ol ) (633% 5 <14 m¥/min o_lage Cul
92 (1) OAN B elall @ guia t=0 hr Adaalll 8«10 m¥/min o _lae Cul Jaza
102 52 (2) 01380 A 5101.2
Ahr & 0hr oo A8l Saalinall sl o) ) o sllaall

Reservoir Capacity

Hydraulic Gradient level
in m for reservoir at

inm? Node 1 Node 2
0 100.00 98.00
1000 100.60 98.80
2000 101.20 99.60
3000 101.80 100.40
4000 102.40 101.20
5000 103.00 102.00
6000 103.60 102.80
Tab: 3-1
Node Nodal Demand in m*min at time
0 hr 4 hr 8 hr 12 hr 16 hr 20 hr 24 hr
3 1.0 2.0 3.0 3.0 2.0 2.0 1.0
4 0.8 1.6 2.0 2.6 1.2 1.6 0.8
5 1.0 3.0 4.0 2.0 4.0 2.0 1.0
6 0.6 1.6 1.0 1.2 2.0 1.4 0.6
Total 34 8.2 10.0 8.8 9.2 7.0 34
Demand
Tab: 3-2
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Time interval Hours Total Network demand m®
0-4 1488
4-8 2256
8-12 2304
12-16 2184
16-20 1992
20-24 1296
Tab: 3-3
) (2] (5
A

1-3 Jsal
H1(0)=101.2 m so V1(0)=2000 m?, H2(0)=102 m so V»(0)=5000 m®,
d3(0)=1 m*/min, qa(0)= 0.8 m*/min, gs(0)=1 m*/min, gs(0)= 0.6 m*/min,
reanBY 8 AN <l ) ) i =0 hr Ja) e (oSl Jaladi o) jaly
Q1(0)=-0.7853 m*/min, Q,(0)=-0.1996 m*/min,
Q3(0)=-1.3853 m*/min, Q4(0)= 1.2799 m*/min,
Qs(0)= 0.2804 m*/min, Q¢(0)= 1.3196 m*/min,
Q+(0)=-0.7196 m*/min,
A.ul\éd).mjjpl\ L._qu.d\
H3(0)=101.268 m ,H4(0)=101.21 m , H5(0)=101.172 m , Hg(0)=101.499 m,

il Al £ sl

01=-(Q1+Q2 )=-(-0.3853-0.1956) (1) o)
=0.5849 m*/min S

02=Q3-Q4-Qs =-1.3853-0.2799-1.3196 (2) O‘).ﬂ‘
=-3.9849 m*/min o

&

ol AN Che b el ¢0-4 hr Bl YA s il AN o olaldl ol ek
AV (0,4)=0.5349*240 =140.38 m®, AV, (0,4)= -3.9349*240=-956.38 m?>
S AV(0,4)=0.5349*240-3.9349*240=-816 m®

1488 m° 58 3-3 Jsaall (e 0-4 hr 3Nl IS Al JSH SISt aaa
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E(0,4)=-816+1488 =672 m®
e1(0,4)=140.38/816*672= 115.6 m°
e2p(0,4)=-956.38/816*672= -787.6 m’
uﬁl_i LS t=4 hr idaall) L;J A_I\_w\);j\ L;:A a\,pd‘ psa
Vip(4)= V1(0)+ AVy (0,4)+ e1(0,4)
=2000+140.38+115.6=2255.98 m®
V2p(4)= V2(0)+ AV, (0,4)+ e2,(0,4)
=5000-956.38-787.6 =3256.02 m’
el | (1) Jsaadl s (2) 5 (1) Gl AN g gasiias O JAN) pas A83le (46
Hip(4)=101.2 +255.98/1000*(101.8-101.2)=101.354 m
H2p(4)=100.4 +256.02/1000*(101.2-100.4)=100.605 m
93(4)=2 m*min, gs(4)= 1.6 m*min, gs(4)=3 m*min, g¢(4)= 1.6 m*/min.
0l A e Oladl Jame Jary (Sl da 6 aly
01(4)=-4.2086 m*/min, g,(4)= -3.9914 m*/min
t=4 hr 4daall) < cl HAd) g1 8 s
ol AN sbial) o s (51 58 A Undll (il 3ale)
E(0,4)=[(0.5849-4.2086)+(-3.9849-3.9914}]*240/2+1488 =96 m>.
e1¢(0,4)=(0.5849-4.2086)/[(0.5849-3.9849)+(-4.2086-3.9914)]*96
=29.99 m® (outflow)
e1¢(0,4)=(-3.9849-3.9914)/[(0.5849-3.9849)+(-4.2086-3.9914)]*96
=66.01 m® (outflow)
Q\.\\);J\ u.‘. NE| S @\M
Vic(4)= V1(0)+[qs (0)+qu(4)]*At/2+ e1.(0,4)
=2000+(0.5949-4.2086)*240/2-29.99=1535.17 m°
Vae(4)= V2(0)+[g2 (0)+02(4)]*At/2+ 2:(0,4)
=5000+(-3.9849-3,9914)*240/2-66.01=3976.83 m?
i O JS aaall il A83e (e g
Hip(4)- Hic(4)=101.354-100.921 = 0.433 m.
H2p(4)- Hac(4)=100.605-101.181 = -0.576 m.
4-3 0520 ¢0.001 A5 sale are s
: 98 0-4 hr 4aia 3l 5 _jall Aleall Jal)
Q1(4)= 0.9525 m*/min, Q,(4)=2.1981 m*/min, Q3(4)=-1.0474 m°min,
Q4(4)=1.3983 m*/min, Qs(4)= 1.9962 m*/min, Q¢(4)= 2.6036 m*/min,
Q:(4)= 1.0037 m¥/min.
qu(4)= -3.1506 m*/min, go(4)= -5.0494 m*/min.
V1(4)=1671.7 m® V,(4)=3841.2 m°,
Hi(4)= 101.003 m, Hy(4)= 101.073 m, Hs(4)= 100.639 m,
Ha(4)= 100.143 m, Hs(4)= 98.704 m, Hg(4)= 99.308 m,
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lteration | Predicted flow m®min, t=4 hr, for | Predicted flow m®*min, t=4 hr, for
steps Res 1 Res 2 Res 1 Res 2

initial 0.58 -3.9849 100.921 101.191

1 -4.2081 -3.9918 101.021 101.048

2 -2.9072 -5.2928 100.998 101.079

3 -3.2056 -4.9935 101.004 101.072

4 -3.1376 -5.0624 101.002 101.073

5 -3.1534 -5.0465 101.003 101.072

Tab: 3-4

‘WaterCad zeebi_yw AVl EPS Siaall (a3l 3lSkacall Al s

‘Pattern <ol saaall Jaad JS55

5 (332l e = 93 3all 58illy ) Junction Editor 338c Jaxa 338U =38 - ]
.Demand 4w s LI

A ganll LU 5 (V) Ll L pemand bl ¢(danl) Jaaill sl -2
Baa ol sl &= el

e 4 ¢Ellipsis(...) 0 JWA) caaill 3 gee 8 AL A0S0 bzl -3
Jaadl)

s ot (L3 Add ) baral 4

:Pattern ) s> (3 5ia A -5
Label Jis &Ll au) A€ 1.5
.12:00:00 AM Jis ¢dadd e Start Time g5 -2-5
0.5 Ji dad e starting Multiplier a5 -3-5
.Stepwise U 33 Format <l -4-5
times, multipliers < juzaall 5 a3V J331 Pattern table Js2all 8 -5-5
.Pattern Manager () 52 s2ll ¢l die ok Jaraial -6-5

Saie Jara ) 32 92ll 5 pattern Manager 02 Y ok daraal -6

. glhaall Jaaill Al pattern list daedl) 48 (§ g2ia 4 -7

B33al) Jaza (g0 g Al ok arazal -8

i pnd) (3555 ¢ b 3y ) Sind) gaea 880 Jane ) J33l -9
Ll asl sy

‘Run EPS ieall (3a WL Sl &) jal

.laaldl Ol LA calculation Options e bl -]

properties manager c—‘-ﬂ Base Calculation Options uif— Gﬁj—«” bzl 2D
3Me) sl Time Analysis Type 4l (e EPS Al

. OK & Validate Ll -3

sl Bl compute bxal -4

63



23)) i)

e zlls el

Aedia -1-4

sl el sl 24

Sl e sl sl aYalee 2324

ASET e gl Judadll ¥ ales da Sl j ) s -4-4

64



S 3ol Yo
Quality:AnaIysis
:dadia -] -4
Aol eld) S i o 4S5 el Glaglaiall Ay e Al ()
ol e i e Al g oSl S ) olal Jlay¥ S e Lall
Aa gansall 3 gaall Gasa dpesisall 5 ALl @l el Sldial gall (A5 G
WHO J& (e
o8 e shaial) sl e Lle | et 4805 53 faslaiad St Jall e
o slaiall Saaliaal) Jall a5 Aa il b ¢ aliall Gue L) 5 ) 5al) Alla
Niai dyie ) By oA A ghaiall & gl e Suadi  lae JiS1 5 ) pm 48005 )2
Ao shaiall @l S JalSl Capa gy Jall 4l A 25350 2 JalS o Jadil]
g omd) eyl 3Rl Jadi S5 a8 5 s pSaabiall 5 Sl Jal) ey
ot et liall e shaiall il & (GSilsouell gl bad ) Jueall a6l
Jii dplee oL plall 4o gill Lol sl okl e Hsal e Jsaall 5 2kl
slall allad Hshi axi daa) a5 Aok ki a5l AL Ll
Sl 8 de sl

1l o gil) Judadl) 24
ke A0 iy (531 ol ) 3 gl ke g ASWEN e i) el
tod Ol il oda (A A elall die g3 ) ekl e daual 95 ) g aad
Water Age Analysis .slell (o gl el -]
Trace Analysis . )asll &l -2
Constituent Analysis .AxluaSIl LSyl 38 523

65



slall 48 jaiey A sl el ga Leosdie 8 slall Jawgll yeall o)
el 138 a0, 3k Bac (e BaBall p3a ) () 3AD)) jabadll (e J sa sl
sldlde gi3aga Ao Bl (clall jae)

sdic (e Aaddl o]- Lo osdie D) AAIN s,00a)) A o aad) e
oLl e g5 ol L -] - kel I AR SIS 5 0 5aN ) 2D (o) ARk
G e 5 yhiee (55 Bl 3508 LSl sl 3 AN 0e £ A
Baal) oda A Ll

b -1- Lesdie & cilSje 385 ale 13 a8l iad cdilaasl LS jall 38 53
AL BaY e A -2- Ledaie (8 S pall 1 58 548 jae Sy Al e ()

S o sil) Jaladl) e dlas -3-4
b5 Ol 8 el Lo i il ysiie aa) skl Akl debel) Alsbeal) Lacs

.l (S Sl

aC,(x,t) u aC, (x,t)
ot OX

) Ay e (e X Bdlasn e L) 3 Sl S 5 Ci(x,8) (Mol s

el Jime o RICIOGH] (L5)6h w5531 (b Al sl sl ey 5 (M)

1D-advective — reactive transport equation .2l s g Jelddl) o Jaill Aalaa &

5 oo Adaalll 8 1) Ja il s oilites ) zlad g A0 e Aalialis Alaleall oda
Xo=0 ¢i Y R 2\:\\_\..:]\ Bac Lf L;L:\;A\ L)ﬂ\ dalaa Xo X GL.\MLJ.CL
C.0t)= @QC, (L. t)+M)) /(Z Q +Qy) 4-2
k k

OB Dlas e Aiaadl S all AT M ok s Jsha iy ¢ Leled Baie Al K V) e aand)
‘_e‘)laj\ JJ.;AAM 3l e :Qsj- ¢ J 3asal ‘;\
Di s Al Bade ¢ jurie ele guiar O 33 A (sl b i) dlalas
1
C.(t =———JC(L,t)Q.z+V,(t t 4-3
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New>Child 33 sk AN ¢Analysis> Scenarios bzl -1-3
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Jas 8 cproperties box il waall g jlisdl e = 53 30 ki 223
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«Analysis > Calculation Options Jasal -3-3
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-7-3
Age Analysis= current. J2a) Scenarios tah 4w s Jarazal -4
Compute bzl -5

New > New Color Coding ¢Pipe ¢ View > Element Symbology &) -6

.Calculate Range Ja%a! ¢<Field Name=Age(Calculated) il -7

OK ¢ Apply ¢ Initialize bl -8

-9

1l sSall 380 5 Jalas

.New ,Constituent Alternative BEPIY ¢Analysis>Alternatives ) -1

8 7 93 e o 5 o) e -2

.Constituent manager C—"ﬂj «Constituent menu _)) s> Ellipsis bl -3

\Wall Reaction ,Bulk Reaction <2lazall Ja2) Chiorine Lable dasal -4
.dialog box (58 Diffusivity

.Close bzl | J 8l 448y a8 J&) 5 Unlimited Concentration ale -5

Constituent (s Chlorine _33) <Constituent Alternative Editor () = -6
.Bulk Reaction (» <l Pipe tab Jazial ¢list box

Valve 4u s s Pump 4xsS s Junction dmsd 3 Y1 Sl Jaal -7
.(0.5 mg/l) s Tank 4w s (2 mg/l) Reservoir 4y o0 (2 mg/l)

.Alternatives Manager _s Editor &el -8

\leans Scenario Management>New>Child ksl Mas Scenario «aal -9

Alternative Constituent= Jill gaia 33all 5 5Ll = 50 50 laza -10

Al gLl = 93 3 Jakaa Calculation Options daaal 11

.Close Ja#al Calculatin Type=Constituent o2 -12

.Compute > Batch Run Ja&al Scenario Tab & -13

.Scenario Manager (3¢ .Batch Ja#ual &3 Chlorine Analysis &) -14

.current Scenario = 2l s )bl Al -15

.color code by Calculated Concentration ¢color coding &< -16

-17
wi Step 3: Performing a Trace Analysis

A trace analysis determines the percentage of water at all nodes and links in the

system from a specific source node (the trace node). In systems with more than one
source, it is common to perform multiple trace analyses using the various source

nodes as the trace nodes in successive analyses. For this run, you will perform a trace

analysis to determine the percentages of water coming from the tank.

1. Select Analysis > Alternatives.
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10.
11.
12.

13.

Click the Trace alternative to highlight it.

Click New.

Name the new alternative Trace Analysis for Tank, and double-click to open.
Click the Ellipsis (...) next to the Trace Element drop-down menu and select
the Tank from the drawing.

Click on the Tank tab to make sure that the initial trace percentage is set to
zero, and close the editor.

Close the Alternatives Manager.

Next, set up a new scenario to run an Extended Period Simulation
incorporating the new alternative.

a.
b.

o

g.

Select Analysis > Scenarios.

Create a new child for the Age Analysis scenario by highlighting it and
clicking New > Child Scenario.

Enter Trace Analysis as the new scenario name.

Double-click on the new scenario to open the Properties dialog box.
Under the Alternatives Trace field, select Trace Analysis for Tank
from the drop-down menu.

Click the Calculation tab. On the Calculation tab, set the Calculation
Type to Trace.

Click Close to exit the dialog box.

Go to Analysis > Scenarios and click on Batch Run.

Select the new Trace Analysis scenario and click Batch.

Click Yes and OK to accept the message boxes. Close the Scenario Manager.
Use color coding (by Calculated Trace), tables, and graphs to view the results
of this run. As you scroll through the time periods using the EPS Results
Browser, notice how the colors spread outward from the tank during periods
when the tank is draining and recede when the tank begins to fill.

Close the open dialog boxes and save this project
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Roughness coefficient
N —
float fr(int i<float qq){sf=7.;

if(unit==1)visc=1.301e-6;if(unit==2)visc=1.201e-5;

re=1.27374*fabs(qq)/(d[i]*visc);de=prof[i]/d[i];

if(re<2100){if(re<100) return .64; else return 64./re ;}

else{ do{sfl=sf; sf=1.14-2.*log10(de+9.35*sf1/re);}
while (fabs(sf-sf1)>1.e-6); return 1./sf/sf;}

il eV ARk o) BT A )l A e
Lagrange's interpolation
float Lagrange (float *gp<float *hp «float g <int n¢int k){
ndeg2=ndeg/2; ndegh=ndeg-ndeg2; m=n-1;
for (i=0;i<n;i++){
ql[il=ap[il*(rpm[K] * pmparl[k]); hi[i]=hp[i]*pow(rpm[K]<2); }
for (i=0;i<n-1 ;i++)
if (9> ql[i]) && (q <=ql[i + 1])) {
im=iif(q==ql[i +1])im=i+1gotol; }
I:if ((q <= ql[0]) || (ndeg2 >=fabs(im - 1))){
if (q<=ql[0]) im=0;i1=0;i2 =ndeg;leg=1; }
else if ((g >=qgl[m]) || (ndegh >=m - im)){
if (>=gl[m]) im=m; il =m - ndeg; i2 =m;leq=1; }
else {il =im - ndeg2;i2 = im + ndegh;leq=1;}
if (leq){
for(ii=0¢i=i1;i<=i2;ii++<i++){ coel[ii]=hl[i];
for(j=il;j<=i2;j++){
if(j'=i)coe[ii]=coe[ii]/(al[i]-ql[j]);} }leq=0; }
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for(ii=0<h=0.¢i=i1;i<=i2;ii++¢i++){ hh=coe]ii];
for(j=il;j<=i2;j++){ if(j!=i)hh*=(q-ql[j]);} h+=hh; }

if(h>=0)return h;if(h<O)return h=0;

}

1 shaall 48 ylay Voo Alea Jadpa )l A o
/I Solve Egs
-
#define TINY 1.0e-20;
void dcompos(float **ac¢int n¢int *indx«float *d) {
int il<imax«<j1¢l;float aamax<dum<sum«temp;float *vv;
vv=(float*)calloc(0+sizeof(float)); *d=1.0;
for(i1=0;i1<n;il++) {aamax=0.0;
for(j1=0;j1<n;j1++)
if ((temp=fabs(a[i1][j1])) > aamax) aamax=temp;
if (aamax == 0.0) printf("Singular matrix at row %3d\n"<il1);
vv[il]=1.0/aamax;
}
for(j1=0;j1<n;j1++) {
for(i1=0;i1<j1;i1++) {sum=a[il][j1];
for(I=0;1<i1;1++) sum -= a[i1][I]*a[1][j1];a[i1][j1]=sum;}
aamax=0.0;
for(il=j1;il<n;il++) {sum=a[il][j1];
for(1=0;1<j1;1++)sum -= a[i1][I]*a[l][j1];a[i1][j1]=sum;
if((dum=vv[il]*fabs(sum))>=aamax)
{aamax=dum;imax=il;}
}
if (j1 !=imax) {
for(1=0;I<n;l++) {
dum=a[imax][l];a[imax][l]=a[j1][I];a[j1][I]=dum; }
*d = -(*d);vv[imax]=vv[j1];
}
indx[j1]=imax;
if (a[j1][j1] == 0.0) a[j1][1]=TINY;

if (j1 !'=n) {dum=21.0/(a[j1][j1]);
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for(il=jl+1;il<n:il++) a[i1][j1] *= dum;}

}
#undef TINY

void finsol(float **acint n<int *indx<float *b) {ii=-1;
for(i=0;i<n;i++) {
ip=indx[i];sum=b[ip];b[ip]=b[il;
if (it1=-0){ for(j=ii;j<i;j++) sum -= a[i][j1*b[j];}
else if (sum!=0.) ii=i; b[i]=sum;
}
for(i=n-1;i>=0;i--) {sum=Db[i];
if(i<(n-1)){for(j=i+1;j<n;j++) sum -= a[i][iT*b[i];}
b[i]=sum/a[i][i]; }
}
void solveq(int n<float **a¢float *b<int itype«float *dd«int *indx){
dcompos(a¢n¢<indx<dd); for(I=0;I<n;l++) *dd*=a[l][l];

finsol(a<n<indx<b);  return;
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Transient Analysis
void transient(float **h«float **v){
t=time;
/[ * compute h and v at interior nodes *
for (i=0;i<np;i++){
k=nparl[i];
for(j=1;j<k;j++){ra=ratio[i]*a[i];
vi=v[i][j]-ra* (v[il[1-vIi[-11); vr=v[i][]-ra*(v[i]G1-vIil[i+1]);
hi=h[i][j]-ra*(h[i1[1-h[i][-11); hr=h[i][j]-ra*(h[]G]-h [T G+1D);
vI2=vI*pow(fabs(vl)<cv);vr2=vr*pow(fabs(vr)«cv);
vnew[i][j]=0.5*(vI+vr+c[i]*(hl-hr));
vnew[i][j]+=0.5*(c[i]*delt*sine[i]*(vI-vr) -ak[i]*(vI2+vr2));
hnew[i][j]=0.5*(hl+hr+(vI-vr)/c[i]+delt*sine[i]*(vI+vr));
hnew[i][j]+=0.5*(-(ak[i]/c[i])*(vI2-vr2));

}

/[ ** compute h and v at junctions **
for(i=0;i<np;i++){cod[i]=0.; cev[i]=0.;}
for(j=0;j<nn;j++){an=0.; de=0.;
if(tqg[j]>=0.)for(j1=0;j1<20;j1++){
qgnl[jl]=agnf]li1l;tvi[il]=tvjli1l;}
if((tag[j]>=0.)&&(t>tqg[j])){// t.grad.change nod i
if(t>=tv1[19]) qj[i]=agn1[19];
else for(j1=0;j1<20;j1++)
if((t>=tv1[jl]) && (t<tvl[j1+1])) {
qi[j]=(t-tvi[jD/(tva[j1+1]-tv1i[j1]);
qilil= agn1fil]+ajfil* (agnl[il+1]-qgnl[j1]);
break;}
}
if(tgs[j]>=0.){// t of rapid change in node i
if(t<tgs[j]) ajlil=asn1[j]; if(t>tas[il) ajlil=asn2[];
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}
for(i=0;i<np;i++){
if(pipjuli]==nodid[j]){
ra=ratio[i]*a[i];
vr=v[iJ[0]-ra*(v[i][0]-V[i][1]); hr=h[i][0]-ra*(h[i][0]-h[i][1]);
cod[i]=-ar[i]*(vr-c[i]*hr-c[i]*delt*vr*sine[i]);
cod[i]+=-ar[i]*(-ak[i]*vr*pow(fabs(vr)«cv)); cev[i]=c[i]*ar[i];
an=an+cod[i]; de=de+cev[i];if(de<=.1e-10) de=.1e-10; }
if(pipjd[i]==nodid[j]){
k=nparl[i];ra=ratio[i]*a[i];
vI=v[i][K]-ra*(v[i][K]-v[i][k-1]); hI=h[i][K]-ra*(h[i][K]-h[i][k-1]);
cod[i]=ar[i]*(vi+c[i]*hl+c[i]*vI*delt*sine[i]);
cod[i]=ar[i]*(-ak[i]*vI*pow(fabs(vl)<cv)); cev[i]=c[i]*ar[i];
an=an+cod[i]; de=de+cev[i]; if(de<=.1le-10) de=.1e-10; }
}
hpp=(an-gj[j])/de;hnod[j]=hpp-nodgl[j];
for(i=0;i<np;i++){
if(pipjuli]==nodid[j]){
hnew[i][0]=hpp; vnewl[i][0]=(-cod[i]/ar[i])+c[i]*hpp; }
if(pipjd[i]==nodid[j]){
k=npar[i];hnew[i][K]=hpp; vnew[i][K]=(cod[i]/ar[i])-c[i]*hpp;}}
}
for(j=0;j<ntank;j++){
for(i=0;i<np;i++){
if(pipju[i]==tankid[j]){
cd=c[i];ra=ratio[i]*a]i];
vr=v[i][0]-ra*(v[i][0]-V[i][1]); hr=h[i][0]-ra*(h[i][0]-h[i][1]);
c3=vr-c4*hr-c4*delt*vr*sine[i]-ak[i]*vr*pow(fabs(vr)<cv);
hnew[i][0]=tankwl[j]; vnew[i][0]=c3+c4*hnew[i][0]; }
if(pipjd[i]==tankid[j]){
c2=c[i];ra=ratio[i]*a[i];k=nparf[i];

vI=v[i][k]-ra*(v[i][K]-V[i][k-1]); hi=h[i][k]-ra*(h[i][K]-h[i][k-1]);

cl=vl+c2*hl+c2*vI*delt*sine[i]- ak[i]*vI*pow(fabs(vl)<cv);

hnew[i][k]=tankwl[j]; vnew[i][K]=c1-c2*hnew[i][K]; }
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}
for(j=0;j<nres;j++){
for(i=0;i<np;i++){
if(pipjuli]==resid[j]){
ra=ratio[i]*a[i];c4=c[i];
vr=v[i][0]-ra*(v[i][0]-V[i][1]); hr=h[i][0]-ra*(h[i][O]-h[i][1]);
c3=vr-c4*hr-c4*delt*vr*sine[i]-ak[i]*vr*pow(fabs(vr)<cv);
hnew[i][0]=reswl[j]; vnew[i][0]=c3+c4*hnew][i][0]; }
if(pipjd[i]==resid[j]){
k=npar[i];c2=c[i];ra=ratio[i]*a[i];

vI=v[i][k]-ra*(v[i][K]-v[i][k-1]); hi=h[i][K]-ra*(h[i][K]-h[i][k-1]);

cl=vl+c2*hl+c2*vI*delt*sine[i]-ak[i]*vI*pow(fabs(vl)<cv);

hnew[i][K]=reswl[j]; vnew[i][K]=c1l-c2*hnew[i][K]; }

}
n=nepmp1l;
for(j=0;j<npmp;j++){
pc=pmpncp[j];m=0;
for(j1=0;j1<pc;j1++)}{
aplitl=pmpalilli1];hph11=pmpp[lhLl; pplitl=pmpt[][1]:}
for(i=0;i<np;i++){
if(pipjd[i]==pmpid[j]){
k=npar[i];ip1l=i;c2=c[i]; pid=pipid[i];ra=ratio[i]*a[i];

vI=v[i][K]-ra*(v[i][K]-V[i][k-1]); hi=h[i][K]-ra*(h[i][K]-h[i][k-1]);

cl=vl+c2*hl+c2*vI*delt*sine[i]-ak[i]*fabs(vl)*pow(vi¢cv); }
if(pipjuli]==pmpid[jI{

ip2=i;c4=c[i]; ra=ratio[i]*a[i];pid=pipid][i];

vr=v[i][0]-ra*(v[i][0]-V[i][1]); hr=h[i][0]-ra*(h[i][0]-h[i][1]);

c3=vr-c4*hr-c4*vr*delt*sine[i]-ak[i]*fabs(vr)*pow(vr<cv);

}

gg=vnew[ip2][0]*ar[ip2];

If((t<bts[j]) &&((bts[j]<btf[j])||(btf[j]<0))) goto pmp20;
If((t<btf[j]) &&((btf[j]<bts[j])||(bts[j]<0))) goto pmp20;
if((aq<0)lI(rpm[i]<=0)){aa=0;rpm[j]=0;pmph[j]= 0;goto pmp20;}
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if((bts[j]<0)&&(btf[j]<0)){
if(pmpst[j]==3){goto pmp20;}// 3=active
if(ompst[j]==4){rpm[j]= 0;goto pmp20;}}// 4=inactive

if(bts[j]<0){
If(t<btf[j]){if(pmpst[j]==3){goto pmp20;}}
if(t>btf[j]){goto pmp15;}}

if(btf[j]<0){
if(t<bts[j]){if(pmpst[j]==4){rpm[j]= 0;goto pmp20;}}
if(t>bts[j]){goto pmp18;}}

if(btf[j]<bts[i]){
if(t<btf[j){if(pmpst[j]==3) {goto pmp20;} }
If((t>btf[j]) &&(t<bts[j])){goto pmp15;}
if(t>bts[j]){goto pmp18;}}

if(bts[j]<btf[j]){
if(t<bts[j]){if(pmpst[j]==4) {rpm[j]= 0;goto pmp20;}}
If((t>bts[j]) &&(t<btf[j])){goto pmp18;}
If(t>btf[j]){goto pmp15;}}

pmpl5: if(pmpwr[j]>0){
if(aq<qp[0]){tn2[i]=pp[0];}
else if(qa>qp[pc-1]){tn2[j]=pp[pc-11;}
else  for(j1=0;j1<pc-1;j1++){
if(ag>=ap[j1] && qg<=qp[j1+1]){
tn2[j]=(qa-ap[i11)/(ap[i1+1]-ap[j1]);

tn2[j]= pplj1]+tn2[j]* (pplil+1]-pp[j1l);

break; }}
rpm[j] = rpm[j] - tn2[j] * delt;
}
else{rpm[j] = rpm[j] +(O-rpmn[j])/tfp[j]*delt; }
if (rom[j]<=0){ rpm[j]=0;pmpst[j]=4;}
goto pmp20;
I pumps restarting
pmpl8:;
if (t < (bts[j] + tsp[i1)) rpmli] = rpm(j] + delt* romn(j] / tsp[j];
else if (t >= (bts[j] + tsp[j])) rpmIj] = rpmnlj];
pmp20:;k=npar[ipl]; rpmr=rpm[j]/rpmn[j];
if(rpom[j]>=0)}{
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pmph[j]=pmphp(j<qa);
pmp25:
vnew[ip2][0]=(c2*c3+cl*c4+c2*c4*pmph(j]);
vnew[ip2][0]/=(c2+c4*ar[ip2]/ar[ipl]);
if(vnew[ip2][0]>0){
ql=vnewl[ip2][0]*ar[ip2];
if(fabs(qg-01)/qg>.01){
99=q1;pmph[j]=pmphp(j<qa);goto pmp25;}
vnew[ipl][k]=vnewl[ip2][0]*ar[ip2])/ar[ipl];
hnew[ip1][k]=(c1-vnew[ip1][Kk])/c2;
hnew[ip2][0]=(vnew[ip2][0]-c3)/c4;} }
if(vnew[ip2][0]<0){
vnew[ip2][0]=0;vnew[ip1][k]=O0;
hnew[ip1][k]=(c1-vnew[ip1][k])/c2;
hnew[ip2][0]=(vnew[ip2][0]-c3)/c4;} }
n=nevivl;
for(j=0;j<nvlv;j++){
npviv=0; ¢5=0;c6=0;
for (j1=0;j1<1L;j1++){ pctl[j]=pcth101]; Ki1[]=kIil]1061]:}
for(i=0;i<np;i++){
if(pipjd[i]==vivid[j])npviv++; if(pipju[i]==vivid[j]))npviv++;}
for(i=0;i<np;i++){
if(pipjd[i]==vivid[i]){
k=npar[i];ivl=i; c2=c[i];ra=ratio[i]*a[i];
vI=v[i][k]-ra*(v[i][K]-v[i][k-1]); hi=h[i][k]-ra*(h[i][K]-h[i][k-1]);
cl=vl+c2*hl+c2*vI*delt*sine[i] -ak[i]*vI*pow(fabs(vl)<cv);
c6+=2*g*cl/c2;
}
if(pipju[i]==vivid[j]){
Iv2=i;c4=c[i];ra=ratio[i]*a[i];
vr=v[i][0]-ra*(v[i][0]-V[i][1]); hr=h[i][0]-ra*(h[i][0]-h[i][1]);
c3=vr-c4*hr-c4*delt*vr*sine[i]-ak[i]*vr*pow(fabs(vr)«cv);
c5+=2*g/c4;c6+=2*g*c3/c4;
}
}c5+=2*g*ar[iv2]/(ar[ivl]*c2);
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if(vlivg[j]==1){// 1=if graduate vlv c\o
t0=tcO[j];t1=tc1[j];t2=tc2[j]; pO=poO[j];p1=pol[j];p2=po2[j];
if(t<=t0) openv = p0;
else if (t> 10 && t < tl1) openv = p0+ (t - t0) / (t1 - t0) * (p1 - p0);
else if (t>=t1 && t<t2) openv =pl + (t-tl)/ (12 - t1) * (p2 - pl);
elseif (t>=tc2[j]) openv =po2[j];
}
if(vivs[j]==2){// 1 rapid vlv c/o
if(t<tsv[j]) {openv=posO[j];} if(t>=tsv[j]) {openv=posli[j];} }
if (vlvai[n]==1){openv=pai[n];}
for(j1=0;j1<11;j1++){
if((openv >= pctl[j1]) && (openv <= pctl[j1+1])) goto v95;}
vo5:;
ki[j] = (openv - pctl[j1])/(pctl[j1 + 1] - pctd[j1]);
ki[j]= klil[j1]+ Ki[j]* (kli1[j1+1] - klid[j1]); KlI=ki[j];
if (npviv==1){
c5=2*g/c2;c6=2*g*(hatm-c1/c2);k=npar[iv1];
vnew[iv1][k]=c5/(2*kl);
vnew[ivl][Kk]*=(-1+pow((1-4*c6*kl/(c5*C5))¢.5));
if(vnew[ivl][k]>=0) hnew[iv1][k]=(c1l-vnew[iv1][k])/c2;
if(vnew[iv1][k]<0){
vnew[iv1][Kk]=c5/(2*kl);
vhew[iv1][K]*=(1-pow((1+4*c6*kl/(c5*C5))¢.5));
hnew[iv1][k]=(vnew[iv1][k]-c1)/c2;}
¥
if (npvlv==2){//printf("openv=%f\n"<openv);
if((openv<=10)&&(openv>=0)){
vnew[iv2][0]=c5/(2*pow(kl¢2));
vnew[iv2][0]*=(-1+pow((1+4*c6*kl/(c5*Cc5))¢.5));}
if(openv>10){
vnew[iv2][0]=c5/(2*kl);
vnew[iv2][0]*=(-1+pow((1+4*c6*kl/(c5*c5))¢.5)); }
if (vnew[iv2][0]>=0){
vnew[iv1l][k]=vnew[iv2][O]*ar[iv2]/ar[iv1];

hnew[iv1][k]=(c1l-vnew[iv1][k])/c2;
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hnew[iv2][0]=(vnew[iv2][0]-c3)/c4;}
if (vnew[iv2][0]<0){
c5=2*g*(ar[ivl]/(c4*ar[iv2])+1/c2);
vnew[iv1][K]=c5/(2*kl);
vnew[iv1][K]*=(-1+pow((1-4*c6*kl/(c5*Cb))¢.5));
vnew[iv2][0]=vnew[iv1][K]*ar[iv1]/ar[iv2];
hnew[iv1][k]=(c1-vnew[iv1][Kk])/c2;
hnew[iv2][0]=(vnew[iv2][0]-c3)/c4;} }
}
/[ ** locate maximum and minimum heads and h-values **
for(i=0;i<np;i++){
k=npar[i]+1; hpmax[i]=hnew[i][0]-pjugl[i];
hpmin[i]=hnew[i][0]-pjugl[i];vpip[i]=vnew[i][O];
for (j=0;j<k;j++)}{
deltx=I[i]/(npar[i]*(fabs(vnew[i][j])+a[i]));
if(deltx<deltn) deltn=deltx;
head[i][j]=hnew[i][j]-(pjugl[i]+j*[i]/npar[i]*sine[i]);
if(head[i][j]<-10) head[i][j]=-10;
hnew[i][j]=head[i][j]+(pjugl[i]+j*I[i]/npar[i]*sine[i]);
if (head[i][jl<hlow[i][j1){ hlow[i][j]=head[i][j];tlow[i][i]=t;}
if (head[i][j]>hhigh[i][i){ hhigh[i][i]=head[i][j];thigh[i][i]=t;}
if (head[i][j]>phmax) {
ipmax=i;xmax=x[i][j];phmax=head[i][j];ttmax=t;}
if (head[i][jl<phmin){
ipmin=i;xmin=x[i][j];phmin=head[i][j];ttmin=t;}
if(head[i][j]>hpmax]i]) hpmax[i]=head[i][j];
if(head[i][j]<hpmin[i]) hpmin[i]=head[i][j]; }
}
for(i=0;i<np;i++){ k=npar[i]+1;
for(j=0;j<k;j++){  VIilli]=vrew[i]jl:h[i][I=hnew[i][]; } }
/[*** check stability criteria **
if (deltn<=(0.9999*delt)) delt=0.999*deltn;
/[ ** write max and min heads and h-values **
for(i=0;i<np;i++){
k=npar[i]+1;
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for(=0;j<k;j++X{
headmx=hhigh[i][j]; headmx+=-(pjdgl[i]+x[i][j]*I[i]*sine[i]);
headmn= hlow[i][j]; headmn+=-(pjdgl[i]+x[i][j]1*I[i]*sine]i]); 1}

il i a5

main function

void main() {
[[ ***** phegining of analysis *****
steady(h0«v0<h<v);
fprintf(fileout<"\nSec\t vO\t hglO\t head0\n");
for(i=0;i<np;i++){
k=npar[i]+1;
for(j=0;j<k;j++) {
vnO=Vv[i][j];hglO=hnew[i][j];hn0=head[i][j];
fprintf(fileout<"[%d][%d]\t %6.3f\t "<i<j<vn0O);
fprintf(fileout<"%6.3f\t %6.3f\n"<hgl0<hn0);

3}
for(ke=0;ke<25;ke++){ // nt=no. of times

time=(ke+1.)*delt;
printf("ke=%21d<time=%f\n"<ke«time);
fprintf(fileout<"tn=\t %1d\t time\t %f\n"<ke<time);
transient(h¢v);
printf("Sec\t vn\t hgin\t hn\n");
fprintf(fileout<"Sec\t v\t hgl\t head\n");
for(i=0;i<np;i++){
k=npar[i]+1;
for(j=0;j<k;j++) {
vn=vnew[i][j];hgln=hnew[i][j];hn=head[i][j];
printf("[%d][%d]\t %5.2f\t "<i<j<vn);
printf("%5.2f\t %5.2f\n"<hgln<hn);
fprintf(fileout<"[%d][%d]\t %5.2f\t "<i¢jevn);
fprintf(fileout<"%5.2f\t %5.2f\n"<hgIn<hn); }

213



}
timel=time;}
printf("Sec\t hhigh\t hlow\n™);
fprintf(fileout<"Sec\t hhigh\t hlow\n™);
for(i=0;i<np;i++){
k=npar[i]+1;
for(j=0;j<k;j++) {
hh=hhigh[i][i]+(pjugl[i]+j*I[il/npar[i]*sine[i]);
hi=hlow[i][j]+(pjugl[i]+j*I[i]/npar[i]*sine[i]);
printf("[%d][%d]\t %5.2f\t %5.2f\n"<i¢<j¢<hhc<hl);
fprintf(fileout<"[%d][%od]\t %5.2f\t \t %5.2f\n"<i¢<j<hh<hl); }}

fclosure(filein); fclosure(fileout);}
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/I Equations formulation
void deffun(float *f) {

t=time;

for(i=0¢n=0;i<np;i++){k=nparf[i];

for(j=0;j<=k:j++<n++){gnew[i][j]=x[n];hnew[i][j]=x[n+nq]; }}

I pipes equations //

ne=0;j1=0;

for (i=0;i<np;i++){k=npar[i];pip=pipid][i];

for (j=0;j<k;j++)}{
q1[il=(alib1+alill+11)/2;vi=qlill)/ar[il;v2=qlil[i+1]/ar[i];
beta[j]=(h[i][j+1]+h[i][i])+(1-teta)/teta*alfa[i]*(q[i1[]-q[i] 0 +11);
delta[j]=v1*fabs(vl)+v2*fabs(v2);
delta[j]*=-dx[i]*fr(i<q1[i])/(4*g*teta*d[i]);
delta[j]+=(1-teta)/teta*(h[i][j]-h[i][j+1])+gama[i]*q1[i];
nl=ne+2*j;
f[n1]=-hnew[i][j]+hnew[i][j+1]-delta[j];
f[n1]+=gamali]*(gnewli][j]+anewl[i][j+1]);
nl=ne+2*j+1,;
f[n1]=hnew[i][j]+hnewl[i][j+1]-beta[j];
f[n1]+=alfa[i]*(-gnew[i][j]+anew[i][j+1]);

Ine=ne+2*k;

}

nnel=ne;

I nodes equations //

npd1=0;

for(i=0;i<nn;i++){
for(j=0;j<20;j++){tvi[j]=tv[il[il:qgn1[i]=agn[i][il;}
if((tqg[i]>=0.)&&(t>tqg[i])){//t grad.change node i

if(t>=tv1[19]) qj[i]=qgnl1[19];
else  for(j=0;j<19;j++)
if(t>=tvl]j]) && (t<tvl[j+1])) {
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qili]=(t-tviD)/(tvi[i+1]-tvi[i]);
qj[il= qgn1[i] +aj[i]* (qgni[j+1]-qgnl[j]);break:}
}
if (tgs[i]>=0.){// t rapid change node i
if (t<tgs[i]) ailil=asnl[il;if (t>=tqs[i]) qi[i]=qsn2[i];}
nl=nnel+i+npdl;
fn1]=-qj[iJ;
for (j=0;j<np;j++){
if(pipjd[j]==nodid[i]){k=nparj]; f[n1]+=qnew[j][K];}
if(pipjuli]==nodid[iN){f[n1]-=qnew[j][0];} }
nen=nnel+i+npdl;j2=0;
for (j=0;j<np;j++){
if(j2>0) break;
if(pipjd[j]==nodid[i]){
j2++k=npar[jL;j3=i;
for (j1=0;j1<np;j1++){
if(pipju[j1]==nodid[i]){
npdl++;nl=nnel+i+npdl;
f[n1]=hnew[j3][k]-hnew[j1][0]; }
if((pipjd[j1]==nodid[i])&&(j3!=j1)){
npdl++;n1=nnel+i+npdl;k1=npar[j1];
f[n1]=hnew[j3][K]-hnew[j1][k1]; }

1}
}
nne2=nnel+nn+npdl;
1 tank equations Il
nntl=nnez2;
nt=0;

for (i=0;i<ntank;i++){n1=nntl+nt;
for (j=0;j<np;j++){
if (pipjd[j]==tankid[i]){
k=npar[j];f[n1]=hnew[j][K]-tankwl[i]; } }
for (j=0;j<np;j++){
if (pipjulj]==tankid[i]){ f[n1]=hnew[j][0]-tankwl][i]; } }
}

nnt2=nntl1+nt;
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I reservoir equations Il
nnrl=nntz;
nr=0;
for (i=0;i<nres;i++){n1=nntl+nr;
for (j=0;j<np;j++){
if (pipjd[j]==resid[i]){
k=npar[j]; f[n1]=hnew[j][K]-reswl[i]; nr++; } }
for (j=0;j<np;j++){
if (pipjulj]==resid[i]){
f[n1]=hnew [j][0]-reswl[i]; nr++;}}

}
I/l f[1] to f[nn]=1-nn eq’s //x[1] to X[np]=q's in pipes
nnr2=nnrl+nr;
[[****** pmp equations Fkkkkk
nepmpl=nnrz;
npm=0;
for (n=0;n<npmp;n++){ pc=pmpcp[n];
for (j=0:j<pc;j++){ aplil=pmpa[n][i];hpLi]=pmpp[n][l;
if(pmpwr[n]>0)pp[i]=pmpt[n][j];}
m=0; k=nepmpl+n+npm;
f[k]=0;
for (j=0;j<np;j++){

if(pipjdlj]==pmpid[n]){ku=npar[jJ;iu=j;m++:}

if(pipjulil==pmpid[n]){id=j;m++:}

if (m==2) goto pmp10;

pmpl0:;
nl=nepmpl+n+npm;
f[n1]=gnewliu][ku]-gnew[id][0];npm++;
qo=fabs(qnew[id][0]);
if((ke==0)||(ke1>0)){goto pmp20;}
if((t<bts[n])&&((bts[n]<btf[n])||(btf[n]<0))) goto pmp20;
if((t<btf[n]) &&((btf[n]<bts[n])||(bts[n]<0))) goto pmp20;
if((qq<0)||(rpm[n]<=0)){qq=0;rpm[n]=0; goto pmp20;}
if((bts[n]<0)&&(btf[n]<0)){

if(pmpst[n]==3) {goto pmp20;}// 3=active
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if(pmpst[n]==4) {rpm[n]= 0;goto pmp20;}}//4=inactive
if(bts[n]<0){
if(t<btf[n]){if(pmpst[n]==3) {goto pmp20;}}
if(t>btf[n]){goto pmp15;}}
if(btf[n]<0){
if(t<bts[n]){if(pmpst[n]==4) {rpm[n]= 0;goto pmp20;}}
if(t>bts[n]){goto pmp18;}}
if(btf[n]<bts[n]){
if(t<btf[n]){if(pmpst[n]==3) {goto pmp20;} }
if((t>btf[n]) &&(t<bts[n])){goto pmp15;}
if(t>bts[n]){goto pmp18;}}
if(bts[n]<btf[n]){
if(t<bts[n]){if(pmpst[n]==4) {rpm[n]= 0;goto pmp20;}}
if((t>bts[n]) &&(t<btf[n])){goto pmp18;}
if(t>btf[n]){goto pmp15;}}
pmpl5: if(pmpwr[n] > 0){
if(aq < ap[0]){ tn2[n] = pp[0]:}
else if(qq > gp[pc-1]){ tn2[n] = pp[pc-1];}
else  for(j=0;j<pc-1;j++){
if(aq >=ap[j] && qq <= qp[i+1]{
tn2[n]=(qq-apl)/(apli+1]-ap[iD):;
tn2[n]= pp[j]+ th2[n]* (pp[j+1]-pp[il); break;}}
rpm[n] = rpm[n] - tn2[n] * delt;
¥
else{ rpm[n] = rpm[n] +(0-rpmn[n])/tfp[n]*delt; }
if (rpm[n]<=0){ rpm[n]=0;pmpst[n]=4}
goto pmp20;
1 pumps restarting
e
pmp1l8:;
if (t < (bts[n] + tsp[n])) rpm[n] = rpm[n] + delt* rpmn[n] / tsp[n];
else if (t >= (bts[n] + tsp[n])) rpm[n] = rpmn[n];
pmp20:;if(gnew[id][0]<0) goto pmp25;
if(rpm[n]>=0) {nl=nepmpl+n+npm;
if(rpm[n]==0) {hp1=0;hp2=0;pmpst[n]=4;}
if(rpom[n]>0){
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hpl=(ap[n]*ag*qq+bp[n]*qa+cp[n]);
hpl*=rpm[n]*rpm[n]/(rpmn[n]*rpmn[n]); }
f[n1]=hnew[id][0]-hnew[iu][ku]-hpl; }
pmp25: if(gnew[id][0]<0) {n1=nepmpl+n+npm;
hp1=0;hp2=0;pmpst[n]=4;
f[n1]=-klp[n][0]*qnew[id][0]*gnew[id][O];
f[n1])/=(ar[id]*ar[id]*2*g); f[n1]+=hnew[id][O]; }}
nepmp2=nepmpl+npmp+npm;
I falskaiakoled vlv equations folakaiakeialel
nevlivl=nepmp2;
nvl=0;
for (n=0;n<nvlv;n++){
k=nevivl+n+nvl;
npvlv=0;// no-pipe connect to viv
for (j=0;j<np;j++){
if(pipjd[j]==vlvid[n]){ku=npar[j];ivi=j;npviv+=1;}
if(pipju[j]==vivid[n]){iv2=j;npviv+=1; }
if(npvlv==2) break;}
if(vivg[n]==1){ /I 1=vlv graduate
if(t<=tgv0[n])openv=pgvO[n];
else if(t > tgv0[n] && t <=tgv1[n]){
openv=(t-tgv0[n])/(tgv1[n]-tgvO[n]);
openv= pgv0[n]+openv* (pgv1[n]-pgvO[n]);}
else if(t > tgvl[n] && t <=tgv2[n]){
openv=(t-tgv1[n])/(tgv2[n]-tgv1[n]);
openv= pgv1[n]+openv* (pgv2[n]-pgv1[n]); }
else if (t > tgv2[n]) openv = pgv2[n];
}
if (vivs[n]==1){ //1 if yes there rapid c/o vlv
if(t<tsv[n]) openv=psvO[n];if(t>=tsv[n]) openv=psvl[n];}
if (vlvai[n]==1){openv=pai[n]; }
for (j1=0;j1<10-1;j1++){
if ((openv>=pctl[jl])&&(openv<=pctl[jl + 1]))
goto v85;}
v85:ki[n]=(openv-pctl[j1])/(pctl[j1+1]-pctl[jl]);
ki[n]=klil[j1]+ki[n]*(kli1[j1+1]-kli1[j1]);
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if(ki[n]==0) ki[n]=1e-6;kI=Ki[n];
cqk[n]=pi/pow(8*kl¢.5);
cgk[n]=1/(cgk[n]*cgk[n]*pow(d[iv1]<4)*q);
nl=nevivl+n+nvl;
if (npviv==1){
if(openv==0){n1=nevivli+n+nvl;f[n1]=qnew[iv1][ku];}
if(openv>0){
f[n1]=(2*fabs(q[iv1][ku])*gnew[iv1][ku]);
f[n1]+=(-fabs(q[iv1][ku])*q[ivi][ku]);
f[n1]=-cqk[n]*f[n1]+ hnew[iv1][ku]-vivgl[n];}
}
if(npvlv==2){ n1=nevivl+n+nvl;
if(openv==0){
f[n1]=qgnewliv1][ku];
nvl++;n1=nevivl+n+nvl;
f[n1]=gnewliv2][0];
}
if(openv>0){
f[n1]=gnewliv1][ku]-gnew[iv2][O];
nvl++; n1=nevivl+n+nvl;
f[n1]=2*fabs(q[iv1][ku])*qnew][iv1][ku]
f[n1]+=-fabs(q[iv1][ku])*q[iv1][ku];
f[n1]=-cqk[n]*f[n1]+hnew[iv1][ku]-hnew[iv2][O];
} } }

nevliv2=nevlvl+ nviv+nvl;  net=neviv2;}
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Meshfree Computational method

// *hhhhhkhkkkhkhkhkhiikhikhkhkkhdhihiiiix

#define TINY 1.0e-20;
void dcompos(float **a¢int n¢int *indx¢float *d) {
int il¢imax¢jl¢l;float aamax<¢dum¢sum¢temp;float *vv;

vv=(float*)calloc(n¢sizeof(float)); *d=1.0;
for(i1=0;il<n;il++) {
aamax=0.0;
for(j1=0;j1<n;j1++)
if ((temp=fabs(a[i1][j1])) > aamax) aamax=temp;
if (aamax == 0.0) printf("S.mat at row %3d\t"¢i1);vv[il]=1.0/aamax;}
for(j1=0;j1<n;j1++) {
for(i1=0;i1<j1;i1++) {
sum=a[il][j1]; for(I=0;I<il;l++) sum -= a[i1][]*a[l][j1];a[i1][j1]=sum;}
aamax=0.0;
for(il=jl;il<n;il++) {
sum=a[il1][j1];
for(1=0;1<j1;1++)sum -= a[il][I]*a[1][j1];a[i1][j1]=sum;
if((dum=vv[il]*fabs(sum))>=aamax){aamax=dum;imax=il;}}
if (j1 !=imax) {
for(1=0;l<n;l++) {
dum=a[imax][l];a[imax][l]=a[j1][I];a[j1][]=dum;}
*d = -(*d);vv[imax]=vv[j1]; }
indx[j1]=imax;
if (@[j1][j1] == 0.0) a[j1][j1]=TINY;
if j1 1= n) {dum=1.0/(a[j1][j1]);
for(il=j1+1;il<n;il++) a[i1][j1] *= dum;}
} free(vv);
}
#undef TINY

void finsol(float **a¢int n¢int *indx¢float *b) {
inticiicip¢j;  float sum;
ii=-1;
for(i=0;i<n;i++) {
ip=indx[i];sum=Db[ip];b[ip]=bl[i];
if (ii 1= -){for(j=ii;j<i;j++) sum -= a[i][j]*b[j]1;}
else if (sum!=0.) ii=i; b[i]=sum;}
for(i=n-1;i>=0;i--) {
sum=b[i];if(i<(n-1)){
for(j=i+1;j<n;j++) sum -= a[i][j]*b[j]; }b[i]=sum/a[i][i];}

}
void solveq(int n¢float **a¢float *b¢int itype¢float *dd¢int *indx){

intl;

dcompos(a¢n¢indx¢dd);for(I=0;l<n;l++) *dd*=a[l][l]; finsol(a¢n¢indx¢b);return;
}
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/! friction function  //

// *kkkhkkkik

double fr(int i<float gf){

float sfl1¢sf=7.¢re<de;double visc;
if(unit==1)visc=1.301e-6;if(unit==2)visc=1.201e-5;
re=1.27374*fabs(qgf)/(d[i]*visc);de=prof[i]/d[i];
if(re<2100){if(re<100) return .64; else return 64./re;}
else{ do{ sfl=sf; sf=1.14-2.*log10(de+9.35*sf1/re);}
while (fabs(sf-sf1)>1.e-6);
return 1./sf/sf;}

}
/! node demand //

float dnt(int nd¢float t){

int i¢j;float g1;float tv1[25]¢qgnl[25];
i=nd;
for(j=0;j<20;j++){qgn1[j]=nqg[i]i];tv1[i]=tva[il[i];}
if((tgg[i]>=0.)&&(t>tqg[i])){// t.grad.change node i
if(t>=tv1[19]) qj[i]=qgni[19];
if(t<tv1[19])
for(j=0;j<20;j++)
if(t>=tvl]j]) && (t<tvl[j+1])) {
qj[i]=(t-tvi[j])/(tvi[i+1]-tvi[i]);qili1*=(agn1[i+1]-agni[i]);
qj[i]+=qgn1[j];break;} }
if(tqs[i]>=0.){ // t.sudden change node i
if(t<tgs[i]) ajlil=ngs1[i];if(t>=tas[i]) aj[i]=ngs2[i]; }return q1=qj[i];}
float pres(int nr¢float t){
float p;
return p=(reswl[nr]);

}
float ptan(int nt¢float t){

float p;

return p=(tankwl[nt]);
}

float klil(int nv¢float t){
int I¢n¢j;float ki1 <klil[25]¢pot1[25];

n=nv;
for(j=0;j<20;j++){kli1[j]=kli[n][j];pot1[j]=pot[n][i];}
if(vivg[n]==1){ /I 1=vlv theres graduate

if(t<=tgvO[n]) openv = pgvO[n];
else if (t > tgv0[n] && t < tgvi[n]){
openv=(t-tgvO[n])/(tgv1[n]-tgvO[n]); openv*=(pgv1l[n]-pgv0[n]);openv+=pgvO[n];}
else if (t >=tgvl[n] && t <tgv2[n]){
openv=(t-tgv1[n])/(tgv2[n]-tgv1[n]);
openv*=(pgv2[n]-pgv1[n]);openv+=pgv1[n];}
else if (t >=tgv2[n]) openv = pgv2[n];}
if(vlvs[n]==1){ //1=vlv sudden c/o
if(t<tsv[n]) openv=psvO[n];if(t>=tsv[n]) openv=psvli[n];}
if(vlvai[n]==1){openv=pai[n]; }
for(1=0;1<11-1;1++){if((openv >= pot[n][l]) && (openv <= pot[n][l + 1]))goto v85;}
v85:ki[n]=(openv - pot[n][I]) / (pot[n][l + 1] - pot[n][I]);
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ki[n] = kli[n][1] + ki[n] * (kli[n][1+1] - KIi[n][I]);
if(ki[n]==0) ki[n]=1e-6;kl1=ki[n];
return Kl1=Ki[n];

}

float rpmc(int npme¢float t¢int ip2){
int j¢jl¢pc;
float rpm1¢qq;float gp[100]¢<hp[100]¢pp[100];
Jj=npm; pc=pmpcp[j];

for (j1=0;j1<pc;j1++){
qp[j1]=pmpqLi]Li1];hp[il]:pmpp[i][jl];
ppLi]l=pmpt[]Gil:}
if((t<bts[j]) &&((bts[j]<btf[j])||(btf[j]<0))) goto pmp20;
if((t<btf[j]) &&((btf[j]<bts[j])||(bts[j]<0))) goto pmp20;
qq=v[ip2]*ar[ip2]; |
if((qq<0)||(rpm[j]<= 0)){qq=0;rpm[j]=0; goto pmp20;}
if((bts[j]<0)&&(btf[j]<0)){
if(pmpst[j]==3) {goto pmp20;}//3=active
if(pmpst[j]==4) {rpm[j]= 0;goto pmp20;}}//4=inactive
if(bts[j]<0){if(t<btf[j]){
if(pmpst[j]==3){goto pmp20;}}if(t>btf[j]){goto pmpl15;}}
if(btf[j]<0){if(t<bts[j]){
if(pmpst[j]==4) {rom[j]= 0;goto pmp20;} }if(t>bts[j]){goto pmp18;}}
if(btf[j]<bts[j]){
if(t<btf[j]){if(pmpst[j]==3) {goto pmp20;}}
if((t>btf[j]) &&(t<bts[j])){goto pmp15;}
if(t>bts[j]){goto pmp18;}}
if(bts[j]<btf[j]{
if(t<bts[j]){if(pmpst[j]==4)}{rpm[j]= 0;goto pmp20;}}
if((t>bts[j]) &&(t<btf[j])){goto pmp18;}
if(t>btf[j]){goto pmp15;}}
pmpl15:if(pmpwr[j] > 0){
if (qq < ap[01){tn2[j] = pp[0]}
e:se if (qq > gp[pc-1]){tn2[j] = pp[pc-1];}
else
for(j1=0;j1<pc-1;j1++){
if(qq >=qp[j1] && qq <= gp[jL+1]){
tn2[j]=pp[1l;

tn2[j]+=(qa-apLi1)*(ppO1+11-ppi1])/(aplil+1]-ap[j1]);

break;}}
rpm[j] = rpm[j] -tn2[j] * delt;
}
else{rpm[j] = rpm[j] +(O-rpmn[j])/tfp[j]*delt;}
if (rpom[j]<=0){ rpm[j]=0;pmpst[j]=4:}
goto pmp20;
Il pumps restarting Il

pmp1l8:;
if(t<(bts[j] + tsp[j])) rpm[j] = rpm[j] + delt* rpmn{j] / tsp[j];
else if(t>=(bts[j] + tsp[j]))rpm[j] = rpmn[j];
pmp20:;
reom1=rpm[j];
return rpmi;
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float dlhi(i){
int j¢ju¢jd;float dh;
ju=pipju[i];jd=pipjdl[i];
for(j=0;j<nn;j++){
if(ju==nodid[j]) {jup[i]=(nodgl[jI+hm[j]);}
if(jd==nodid[j]) {idp[i]=(nodgl[i]+hm[j]);}}
for(j=0;j<npmp;j++){
if(ju==pmpid(j]) {jup[i]=(hpmp2[j]+pmpgl[i]):}
if(jd==pmpid[j]) {jdp[i]=(hpmpl[j]+pmpgl[j]);}}
for(j=0;j<nvlv;j++){
if(ju==vivid[j]) {jup[il=(hviv2[j]+vival[j]);}
if(jd==vivid[j]) {idp[il=(hvIv1i[j]+Vvival[j]);}}
for(j=0;j<ntank;j++){
if(ju==tankid[j]) {jup[i]=(tankwI[j]);}
if(jd==tankid[j]) {jdp[i]=(tankwl[j]);}}
for(j=0;j<nres;j++){
if(ju==resid[j]) {jup[i]=(reswl[j]);}
if(jd==resid[j]) {jdp[i]=(reswl[j]);}}
return dh=jup[i]-jdp[i];
}
// boundary fun //
void boundary(){
nj=0;if(t>0)it++;
if(t==0){
for(j=0;j<nn;j++) {nhglu[j]=0;nhgld[j]=0;}
for(j=0;j<ntank;j++){nptu[j]=0;nptd[j]=0;}
for(j=0;j<nres;j++) {npru[j]=0;nprd[j]=0;}
for(j=0;j<nvlv;j++) {npvu[j]=0;npvd[j]=0;}
for(i=0;i<np;i++){ju=pipjuli];jd=pipjd[i];
for(j=0;j<nn;j++){
if(ju==nodid[j]) {
pjugl[i]=nodgl[j]; nhgld[j]++;elvuli]=pjugl[i];
p[i]=(nodgl[j1+hO[j1);h[i]=p[i]-pjugl[i];}
if(jd==nodid[j]) {pidgl[i]=nodgl[jI;nhglufj]++;}}
for(j=0;j<npmp;j++){
fu=pmpidiDe
pjuglli]=pmpgl[jJ;elvuli]=pjuglfi];
plil=(hpmp2[j]+pmpgl[]):hLil=plil-pjugl[i]:}
if(Gd==pmpid[j]) {pidgl[i]=pmpgl[i];}}
for(j=0;j<nvlv;j++){
if(u==vivid[j]) {
piuglli]=vivgl[il;npvd[j]++;elvu[i]=pjugl[i];
pli]=(hviv2[jJ+vivgl[j]);h[i]=p[i]-pjugl[i];}
if(jd==vlvid[j]) {pidgl[i]=vIval[jl;npvuli]++:}}
for(j=0;j<ntank;j++){
if(ju==tankid[j]) {
pjugl[i]=tankgl[j];nptd[j]++;elvu[i]=pjugl[i];
p[i]=(tankwl[i1);h[i]=p[i]-pjugl[i];}
if(jd==tankid[j]) {
pidgl[i]=tankgl[j];nptu[j]++;elvu[i]=pjdgl[i];}}
for(j=0;j<nres;j++){
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if(ju==resid[j]) {
pjugl[i]=resgl[j];nprd[j]++;elvuli]=pjugl[i];
p[i]=(reswl[j]);h[i]=p[i]-pjugl[i];}

if(jd==resid[j]) {pjdgl[i]=resgl[j];nprd[j]++;elvu[i]=pjdgl[i];}}

¥
for(i=0;i<np;i++){ju=pipju[i];jd=pipjd[i];
for(j=0;j<ntank;j++){
if(ju==tankid[j]) elvu[i]=pjugl[i];if(jd==tankid[j]) elvu[i]=pjdgl[i]; }
for(j=0;j<nres;j++){
if(ju==resid[j]) elvu[i]=pjugl[i];if(jd==resid[j]) elvu[i]=pjdgl[i];}
¥

for(i=0;i<npmp;i++) {btf[i]=2*delt;tfp[i]=4*delt;}
for(i=0;i<nvlv;i++) {tsv[i]=2*delt;}
for(i=0;i<np;i++){
si0=1;si1=1/(ro*a[i]);si2=1;si3=1/(-ro*a[i]);
eta00[i]=si0*v[i]+si1*p[i];etaO[i]=eta00[i];
etaO1[i]=si2*v[i]+si3*p[i];etal[i]=eta01[i];dIh[i]=dlIhi(i);}
}
if(t>0){
for(i=0;i<np;i++){ju=pipjuli];jd=pipjd[i];
s0=.5;s1=.5;52=.5*ro*a[i];s3=-.5*ro*a[i];
si0=1;si1=1/(ro*a[i]);si2=1;si3=-1/(ro*a[i]);
for(j=0;j<ntank;j++){
if((ju==tankid[j])){ nj++;
eta20=etal[i]; pt=ptan(j¢t);dsO=.5*ro*a[i];ds1=-.5*ro*a[i];
alfa0=-ds1/ds0;beta0=1/ds0; etaO[i]=alfa0*eta20+beta0*pt;
3
for(j=0;j<nres;j++){
if((u==resid[j])){nj++;
eta20=etal[i]; pr=pres(j¢t);ds0=.5*ro*a[i];ds1=-.5*ro*a[i];
alfa0=-ds1/ds0;beta0=1/ds0; etaO[i]=alfa0*eta20+beta0*pr;
s
for(j=0;j<ntank;j++){
if((jd==tankid[j])){ nj++;
etalO=etaO[i];dIh[i]=dIhi(i);pt=ptan(j<t)+dIh[i];
ds2=.5*ro*a[i];ds3=-.5*ro*a[i];
alfal=-ds2/ds3;betal=1/ds3; etal[i]=alfal*etalO+betal*pt;
s
for(j=0;j<nres;j++){
if((jd==resid[j])){nj++;
etalO=etaO[i];dIh[i]=dlhi(i);pr=pres(j¢t)+dlInh[i];
ds2=.5*ro*a[i];ds3=-.5*ro*a]i];
alfal=-ds2/ds3;betal=1/ds3; etal[i]=alfal*etalO+betal*pr;
1}
for(j=0;j<nn;j++){
if((jd==nodid[j]) &&(nhglu[j]==1)&&(nhgld[j]==0)){nj++;
etalO=etaO[i]; vn=dnt(j¢t)/ar[i];if(vn<0)vn=0;
ds2=.5;ds3=.5;
alfal=-ds2/ds3;betal=1/ds3; etal[i]=alfal*etalO+betal*vn;

b3
for(j=0;j<nviv;j++){
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if((jd==vivid[j]) &&(npvu[j]==1) &&(npvd[j]==0)){ nj++;
etalO=etaO[i];
KI1=kli1(j¢t);b1=kI1/(2*g);h2=-1;h3=0;
al=si0;a2=sil;a3=eta0[i]; all=si2;a21=si3;
vf=al*b2*al*b2-4*a2*b1*(b2*a3-b3*a2);
vi=pow(vf¢.5); vf=(al*b2+vf)/(2*a2*bl);
if (vf<Q)vf=0;
ds2=.5;ds3=.5;
alfal=-ds2/ds3;betal=1/ds3; etal[i]=alfal*etalO+betal*vf;
1
for(j=0;j<nm;j++){
if((nhglu[j]+nhgld[j])>1){nj++;
hglu=nhglu[j];hgld=nhgld[j];hgl=hglu+hgld;
rs0=0;rs1=0;rj0=qj[j];rj1=0;11=0;
/I pipe renum with 11 begin pipe in then out
for(i1=0;i1<2*hgl;il++){
for(j1=0;j1<hgl;j1++)jb[j1][i1]=0;
for(j1=0;j1<2*hgl;j1++)sb[i1][j1]=0;}
for(i=0;i<np;i++){ jd=pipjd[i];if(jd==nodid[j]) {iO=i;break;}}
etau[l1]=eta0[i0]; jb[0][O0]=ar[i0];for(j1=1;j1<hgl;j1++)jb[j1][1]=1;
sb[0][0]=.5;sb[0][1]=.5;
sb[1][0]=.5*ro*a[i0];sb[1][1]=-.5*r0o*a][i0];
for(i=0;i<np;i++){jd=pipjd[i];
if((jd==nodid[j])&&(i0!=i)) {I1++;12=2*I1;
etau[l1]=etaO[i];
jb[O][12]=ar[i];jb[11][12+1]=-1; sb[I2][I2]=.5;sb[I2][I12+1]=.5;
sb[12+1][12]=.5*ro*a[i];sb[12+1][I2+1]=-.5*ro*a[i]; etau[l1]=etaO[i];
+}
for(i=0;i<np;i++){ ju=pipju[i];
if(ju==nodid[j]) {I1++; [2=2*I1,
etad[l1]=etal[i]; jb[O][12]=-ar[i]; jb[I1][I2+1]=-1,;
sb[12][12]=.5;sb[12][I2+1]=.5;
sb[12+1][12]=.5*ro*a[i]; sb[lI2+1][12+1]=-.5*ro*a[i];
etad[l1]=etalli];

+}
for(i1=0;i1<hgl;il++)for(j1=0;j1<2*hgl;j1++){

js[i1][j1]1=0;

for(i2=0;i2<2*hgl;i2++){ js[i1][j1]+=jb[i1][i2]*sb[i2][j1];
3

/Incc[]:system const;right side
/Inc[][]:system coeff(max 4*4)
for(i1=0;i1<hgl;il++){ncc[i1]=0;
for(j1=0;j1<2*hgl;j1++)jclil][i1]=js[i1][1];}
ncc[0]=rjo;
for(j1=0;j1<hgl;j1++){
if(j1>0){dlIh[i0]=dlhi(i0);ncc[j1]+=dIh[i0];} j2=0;
for(i=0¢i1=0;i<np;i++){jd=pipjd[i];
if(jd==nodid[j]) {if(i==i0)goto bl; j2++;
if((j2==j1)&&(j1>0)){
dih[i]=dlhi(i);ncc[j1]+=-dIh[i];}
bl:
nccljl]-= jc[j1][2*i1]*etaO[i];nc[j1][i1]= jc[j1][2*i11+1]; i1l++;
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1}
for(i=0¢i2=hglu;i<np;i++){ ju=pipjuli];
if(jJu==nodid[j]) {
ncclj1]-= je[j1][2*i2+1]*etal[i]; nc[j1][i2]= jc[j1][2*i2];

i2++;
} 1}
11=0;
solveq(hgl¢nce¢ncceitype¢dd¢indx);
for(i=0;i<np;i++){jd=pipjd[i];
if(jd==nodid[j]){ etaO[i]=etau[l1]; etal[i]=ncc][I1];
11++;
1}
for(i=0;i<np;i++){ ju=pipju[i];
if(ju==nodid[j]){ etal[i]=etad[l1];etaO[i]=ncc[I1];
11++;

I3 3,
¥

for(j=0;j<npmp;j++){nj++;jpd=pmpid[j];
rjo=0¢rj1=0; rs0=0;rs1=0;
b1=ap[j];b2=bp[j];b3=cp[j];b10=kIp[j][0]/(2*g);b20=-1;b30=0;
for(i=0;i<np;i++){jd=pipjd[i];
if(jd==jpd) {ppu=i;
etalO=etaO[i]; s0=.5;s1=.5; s2=.5*ro*a[i];s3=-.5*ro*a[i];
si0=1;sil=1/(ro*a[i]); si2=1;si3=-1/(ro*a[i]);
al=si0;a2=sil;a3=eta0[i];a20=si3; dIh[i]=dlhi(i);
pl0=a2*(hpml[j]-dIh[i]); p20=-a20*(hpm[j]-dIh[i]);
jeO=ar[i];je1=0;je2=0;je3=1;
js10=je0*s0+jel*s2;js11=je0*s1+jel*s3;
Js12=je2*s0+je3*s2;js13=je2*s1+je3*s3;
break;
}}
for(i1=0;il<np;il++){ju=pipjulil];
if(ju==jpd) {ppd=il;
eta20=etal[il];
s0=.5;51=.5; s2=.5*ro*a[i1];s3=-.5*ro*a[il];
si0=1;si1=1/(ro*a[i1]); si2=1;si3=-1/(ro*a[i1]);
ad=si2;a5=si3;ab=etal[il];
jeO=ar[i1];je1=0;je2=0;je3=1,;
js20=je0*s0+jel*s2;js21=je0*s1+jel*s3;
js22=je2*s0+je3*s2;js23=je2*s1+je3*s3;
break;
}
¥
{ det=js13*js20-js11*js22;
gama0=(js13*js10-js11*js12)/det; gamal=(js11*js23-js13*js21)/det;
gama2=(js22*js10-js20*js12)/det; gama3=(js20*js23-js22*js21)/det;
delO=-js13/det;del1=js11/det; del2=-js22/det;del3=js20/det;
pl=-bl;p2=-b2-ad4/a5+al*ar[ppd]/(ar[ppu]*a2);
p3=-b3+a6/a5-a3/a2;
}
vd=vO[ppd]; pmph0=(bl*vd*vd+b2*vd+b3);
rpmO=rpm{[j];rpm1=rpm[j}/rpmn[j]; rpm2=pow(rpm[j}/rpmn[j]¢2);
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vd=(-p2+pow((p2*p2-4*pl*p3)¢.5))/(2*pl)*rpml;
pmph[j]=(b1*vd*vd+b2*vd+b3)*rpm2;pmphl=pmph[j];
rpm[j]=rpmc(j¢t¢ppd); rpoml=rpm[j]}/rpmnl[j]; rpm2=pow(rpm[j]/rpmn[j]¢2);
vd=(-p2+pow((p2*p2-4*p1*p3)¢.5))/(2*pl)*rpml;
pmph[j]=(b1*vd*vd+b2*vd+b3)*rpm2;pmph2=pmphl[j];
dih[ppu]=dlhi(ppu);hpm[j]=pmph(j];
p10=a2*(hpm(j]-dIh[ppu]);p20=-a20*(hpm[j]-dlh[ppu]);
if((t<bts[j])&&((bts[j]<btf[j])|(btf[i]<0))) rj1=0;
else if((t<btf[j])&&((btf[j]<bts[j])||(bts[j]<0))) rj1=0;
else rj1=-3.6*(pmph2-pmphl);
if(rpm1>0){vd1l=vd;printf("vd0=%Tf\n"¢vd1);}
if((rom[]>0){
vd=(-p2+pow((p2*p2-4*pl*p3)¢.5))/(2*pl)*rpm1l,;
if(vd>0){
vs=vd*ar[ppd]/ar[ppu];
etaO[ppd]=gamaO*etalO+gamal*eta20;
etaO[ppd]+=del0*rj0+del1*rj1+p10;
etal[ppu]=gama2*etalO+gama3*eta20;
etal[ppu]+=del2*rj0+del3*rj1+p20;
1}
if((rpm[j]==0)
vd=vd1; vs=vd*ar[ppd]/ar[ppu];
etaO[ppd]=gamaO*etal0+gamal*eta20;
etaO[ppd]+=del0*rj0+del1*rj1+p10;
etal[ppu]=gama2*etal0+gama3*eta20;
etal[ppu]+=del2*rj0+del3*rj1+p20;
}
if((v[ppd]<=0)){
vd=0; vs=vd*ar[ppd]/ar[ppu]; dh=b10; rjl=dh*vd*vd;
pl0=a2*(dlh[ppu]);p20=-a20*(dIh[ppu]);
etaO[ppd]=gamaO*etal0+gamal*eta20;
etaO[ppd]+=10*(del0*rj0+del1*rj1+p10);
etal[ppu]=gama2*etal0+gama3*eta20;
etal[ppu]+=10*(del2*rj0+del3*rj1+p20);
1}
for(j=0;j<nvlv;j++){ nj++;
if((npvu[j]+npvd[i])>1){ jvd=vlvid[j];
rj0=0;rj1=0; rs0=0;rs1=0; kl1=kli1(j¢t); b1=kl1/(2*g);b2=-1;b3=0;
for(i=0;i<np;i++){jd=pipjd[i];
if(jd==jvd) {vpu=i;
etalO=etaO[i];
s0=.5;51=.5; s2=.5*ro*a[i];s3=-.5*ro*a[i];
si0=1;si1=1/(ro*a[i]); si2=1;si3=-1/(ro*a[i]);
al=si0;a2=sil;a3=eta0[i];all=si2;a21=si3;
p10=-si1*dInh[i];p20=si3*dIh[i];
jeO=ar[i];je1=0;je2=0;je3=1;
js10=je0*s0+jel*s2;js11=je0*sl+jel*s3;
js12=je2*s0+je3*s2;js13=je2*s1+je3*s3;
break;

1}
for(i1=0;i1<np;il++){ju=pipjulil];
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1}
Y/ t>0

if(ju==jvd) {vpd=il;
eta20=etal[il];
s0=.5;51=.5; s2=.5*ro*a[i1];s3=-.5*ro*a[il];
si0=1;si1=1/(ro*a[i1]); si2=1;si3=-1/(ro*a[il]);
ad=si2;a5=si3;a6=etal[il];
jeO=ar[il1];je1=0;je2=0;je3=1,;
js20=je0*s0+jel*s2;js21=je0*s1+jel*s3;
JS22=je2*s0+je3*s2;js23=je2*s1+je3*s3;
break;
3,
det=js13*js20-js11*js22;
gama0=(js13*js10-js11*js12)/det; gamal=(js11*js23-js13*js21)/det;
gama2=(js22*js10-js20*js12)/det;gama3=(js20*js23-js22*js21)/det;
delO=-js13/det;del1=js11/det; del2=-js22/det;del3=js20/det;
v1l=bl1;v2=-al*b2*ar[vpd]/(a2*ar[vpu])+b2*ad/a5;
v3=-b3+b2*(a3/a2-a6/a5-dlh[vpu]);
vd=(-v2+pow((v2*v2-4*v1*v3)¢.5))/(2*Vv1);
if(vd<0)vd=0; vs=vd*ar[vpd]/ar[vpu]; v[vpd]=vd;v[vpu]=vs;
rj1=0.12*b1*vd*vd;if(openv==100)rj1=0;
etaO[vpd]=gamal*eta20+gama0*etal0;
etaO[vpd]+=1*(del0*rjO+.1*del1*(rj1)+p10);
etal[vpu]=gama2*etalO+gama3*eta20;
etal[vpu]+=1*(del2*rjO+.1*del3*(rj1)+p20);

}/ end boundary function

/I* RUKUST FUNCTION */
void rukus(float t¢float dt <float *y){
int i;int nm; float *yt¢*dyl1¢*dyt¢*dym:; float dth¢th;

nm=nq+nh;

yt=(float *)calloc(nm¢sizeof(float));
dyl=(float *)calloc(nm¢sizeof(float));
dyt=(float *)calloc(nm¢sizeof(float));
dym=(float *)calloc(nm¢sizeof(float));

dth=.5*dt; th=t+dth;
slope(t¢y¢dyl); tea++;

/I 1st sub-step

for(i=0;i<ngh;i++) {yt[i]=y[i]+dth*dy1][i];}

slope(theytedyt);

Il 2nd sub-step

for(i=0;i<ngh;i++) {yt[i]=y[i]+dth*dyt[i];}

slope (theytedym);

I 3rd sub-step

for(i=0;i<ngh;i++) {yt[i]=y[i]+dt*dym[i];dym[i]+=dyt[i];}

slope (t+dteytedyt);

/I 4th sub-step

for(i=0:i<ngh;i++) {y[i]+=dt*((dyL[i]+dyt[i])/6.+dym[i]/3.):}

by

I End of function ruku4s
void ruku(float *dx¢float xb¢float xe¢float er¢<float *y¢float *yt){

int i¢<cof=0;
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float errmeytty¢dtedt5ex1¢x2¢*yori;
float tol=1.e-5¢h1=.01¢hmin=1.e-5;

yori=(float*)calloc(ng+nh¢sizeof(float));
x1=xb; dt=*dx;x2=xe;if((x2-x1)<0) dt=-dt;n2++;
L1: for(i=0;i<ngh;i++) {yt[i]=y[i]; yori[i]=y[i];}
t=x1;if(t==0) t=.000000001; if((t+dt-xe)*(t+dt-xb)>0) dt=x2-t;
L2: dt5=.5*dt;
rukus(t¢dt5¢y);cof++; // Solve with 1/2 inc
rukus(t+dt5¢dt5¢y);tea=0;

rukus(t¢dteyt); /Il Solve with full inc.
errm=0.;x1=t+dt;
for(i=0;i<ngh;i++){ yt[i]=y[i]-yt[i];
if(fabs(y[i])<1.e-7) ytty=yt[i]/(y[i]+1.e-7); else ytty=yt[i]/y[i];
errm=max(errm¢fabs(ytty));}
if(errm==0.){dt*=3.;goto L3;}
else { errm/=er; dt/=pow(errm¢.2);
if(fabs(dt)<1.0e-25){ printf(dt=0 and no solution\n"); return;}
if(errm>1){for(i=0;i<ngh;i++){yt[i]=yori[i];y[i]=yori[i];} goto L2;}}
for(i=0;i<ngh;i++) {y[i]+=yt[i]/15.;}
L3: if(x1==x2) return;
goto L1,
}

// End of function rukust

/ Khkhhhhhkhkkkhkhkhkhkirhiiikikk

// KTEAIAAAAAAAAAAAA K
I FUNCTION SolvEgs
// B R R T 2 2 T S S S e 2 o o

#define TINY 1.0e-20;

void dcompos(float **a¢int n¢int *indx«<float *d) {
intileimax¢jlel;
float aamax<dum¢sum<temp;float *vv;

vv=(float*)calloc(n¢sizeof(float)); *d=1.0;
for(i1=0;il<n;il++) {
aamax=0.0;
for(j1=0;j1<n;j1++) if((temp=fabs(a[i1][j1]))>aamax) aamax=temp;
if (aamax == 0.0) printf("S.mat at row %3d\t"¢il1);vv[il]=1.0/aamax;}
for(j1=0;j1<n;j1++) {
for(i1l=0;i1<j1;i1++) {
sum=a[il1][j1]; for(1=0;I<il;l++) sum -= a[i1][I]*a[l][j1];a[i1][j1]=sum;}
aamax=0.0;
for(il=j1;il<n;il++) {
sum=a[il][j1];
for(1=0;1<j1;1++)sum -= a[i1][I]*a[l][j1];
a[i1][j1]=sum; if((dum=vv[il]*fabs(sum))>=aamax){aamax=dum;imax=il;}}
if j1!=imax) {
for(I=0;1<n;1++){

dum=a[imax][l];a[imax][l]=a[j1][l]; a[j1][I]=dum;} *d = -(*d);vv[imax]=wV][j1]; }

indx[j1]=imax;
if (a[j1][j1] == 0.0) a[j1][1]=TINY; if 1 !'=n) {dum=1.0/(a[j1][j1]);
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for(il=j1+1;il<n;il++) a[i1][j1] *= dum;}
} free(vv);

}
#undef TINY

void finsol(float **a¢int n¢int *indx¢float *b){
inticiicip¢j;  float sum;
ii=-1;
for(i=0;i<n;i++) {
ip=indx[i];sum=Db[ip];b[ip]=b[i];
if (ii 1= -1){for(j=ii;j<i;j++) sum -= a[i][j]*b[j]1;} else if (sum!=0.) ii=i; b[i]=sum;}
for(i=n-1;1>=0;i--) {
sum=b[i];if(i<(n-1)){for(j=i+1;j<n;j++) sum -= a[i][j]*b[j];}b[i]=sum/a[i][i];}
}
void solveq(int n¢float **a¢float *b¢int itype<¢float *dd¢int *indx){
intl;
dcompos(a¢n¢indx¢dd); for(I=0;l<n;l++) *dd*=a[l][l]; finsol(a¢n¢indx¢b);
return;
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